[mule-user] Problem sending mail

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[mule-user] Problem sending mail

Julian de Anquin
I-ve configure an outbound router to send an email on certain
conditions, with this configuration
                        <outbound-router>
                                <router
                                        className="org.mule.routing.outbound.OutboundPassThroughRouter">
                                        <endpoint address="smtp://[hidden email]">
                                                <properties>
                                                        <property name="hostname"
                                                                value="smtp.esabas.com" />
                                                        <property name="fromAddress"
                                                                value="[hidden email]" />
                                                </properties>
                                        </endpoint>
                                </router>
                        </outbound-router>
But when mule tries to send an email to my address, I get the following error.
DEBUG: getProvider() returning
javax.mail.Provider[TRANSPORT,smtp,com.sun.mail.smtp.SMTPTransport,Sun
Microsystems, Inc]
DEBUG SMTP: useEhlo true, useAuth true
DEBUG SMTP: useEhlo true, useAuth true
ERROR 2005-07-14 17:13:10,500 [_smtpConnector#28656482.dispatcher.1]
org.mule.impl.DefaultExceptionStrategy: Caught exception in Exception
Strategy: null
javax.mail.AuthenticationFailedException
        at javax.mail.Service.connect(Service.java:264)
        at javax.mail.Service.connect(Service.java:134)
        at javax.mail.Service.connect(Service.java:86)
        at com.sun.mail.smtp.SMTPTransport.connect(SMTPTransport.java:95)
        at javax.mail.Transport.send0(Transport.java:150)
        at javax.mail.Transport.send(Transport.java:80)
        at org.mule.providers.email.SmtpMessageDispatcher.sendMailMessage(SmtpMessageDispatcher.java:191)
        at org.mule.providers.email.SmtpMessageDispatcher.doDispatch(SmtpMessageDispatcher.java:143)
        at org.mule.providers.AbstractMessageDispatcher$Worker.run(AbstractMessageDispatcher.java:215)
        at org.mule.impl.work.WorkerContext.run(WorkerContext.java:290)
        at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)

I think its trying to use authentication, but I do not know how to disable it.
Any clue?
thanks a lot
Julian
--
Julian Eduardo de Anquin
[hidden email]
Cordoba, Argentina