community 3.0.1 startup errors

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

community 3.0.1 startup errors

Adrian Brenes-2
Centos 5.4 32 bit
JDK: 1.6.0_18 (Sun/Oracle)
Fresh install today
community 3.0.1

I have installed the hello and echo examples (unmodified) and as well was working on a config file using eclipse (helios) with the mule tools (and patched with the lastest mule tools patch http://dist.muleforge.org/mule-ide/wtp-patch/helios

When I run my new readFilePut example config in eclipse I don't get expected behavior but it does not throw java exceptions. When I just start up mule (command line or service (mule start)) mule throws these errors at startup.

Starting the Mule Container...
Wrapper (Version 3.2.3) http://wrapper.tanukisoftware.org
  Copyright 1999-2006 Tanuki Software, Inc.  All Rights Reserved.

INFO  2010-12-16 14:25:57,014 [WrapperListener_start_runner] org.mule.module.launcher.MuleContainer:
**********************************************************************
* Mule ESB and Integration Platform                                  *
* Version: 3.0.1 Build: Not Set                                      *
* MuleSoft, Inc.                                                     *
* For more information go to http://www.mulesoft.org                 *
*                                                                    *
* Server started: 12/16/10 2:25 PM                                   *
* JDK: 1.6.0_18 (mixed mode)                                         *
* OS: Linux (2.6.18-164.15.1.el5, i386)                              *
* Host: localhost.localdomain (127.0.0.1)                            *
**********************************************************************
INFO  2010-12-16 14:25:57,024 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleDeployer: Exploding a Mule application archive: file:/usr/local/mule-standalone-3.0.1/apps/mule-example-echo.zip
INFO  2010-12-16 14:25:57,049 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleApplication: Installing application: default
java.lang.RuntimeException: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
        at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:80)
        at org.mule.module.launcher.DefaultMuleSharedDomainClassLoader.<init>(DefaultMuleSharedDomainClassLoader.java:23)
        at org.mule.module.launcher.DefaultMuleApplication.createDeploymentClassLoader(DefaultMuleApplication.java:301)
        at org.mule.module.launcher.DefaultMuleApplication.install(DefaultMuleApplication.java:100)
        at org.mule.module.launcher.ApplicationWrapper.install(ApplicationWrapper.java:99)
        at org.mule.module.launcher.DefaultMuleDeployer.deploy(DefaultMuleDeployer.java:35)
        at org.mule.module.launcher.DeploymentService.start(DeploymentService.java:108)
        at org.mule.module.launcher.MuleContainer.start(MuleContainer.java:130)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.mule.module.reboot.MuleContainerWrapper.start(MuleContainerWrapper.java:64)
        at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:2788)
Caused by: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
        at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:43)
        ... 13 more
INFO  2010-12-16 14:25:57,068 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleApplication: Installing application: mule-example-echo
java.lang.RuntimeException: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
        at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:80)
        at org.mule.module.launcher.DefaultMuleSharedDomainClassLoader.<init>(DefaultMuleSharedDomainClassLoader.java:23)
        at org.mule.module.launcher.DefaultMuleApplication.createDeploymentClassLoader(DefaultMuleApplication.java:301)
        at org.mule.module.launcher.DefaultMuleApplication.install(DefaultMuleApplication.java:100)
        at org.mule.module.launcher.ApplicationWrapper.install(ApplicationWrapper.java:99)
        at org.mule.module.launcher.DefaultMuleDeployer.deploy(DefaultMuleDeployer.java:35)
        at org.mule.module.launcher.DeploymentService.start(DeploymentService.java:108)
        at org.mule.module.launcher.MuleContainer.start(MuleContainer.java:130)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.mule.module.reboot.MuleContainerWrapper.start(MuleContainerWrapper.java:64)
        at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:2788)
Caused by: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
        at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:43)
        ... 13 more
INFO  2010-12-16 14:25:57,070 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleApplication: Installing application: readFulePut
java.lang.RuntimeException: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
        at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:80)
        at org.mule.module.launcher.DefaultMuleSharedDomainClassLoader.<init>(DefaultMuleSharedDomainClassLoader.java:23)
        at org.mule.module.launcher.DefaultMuleApplication.createDeploymentClassLoader(DefaultMuleApplication.java:301)
        at org.mule.module.launcher.DefaultMuleApplication.install(DefaultMuleApplication.java:100)
        at org.mule.module.launcher.ApplicationWrapper.install(ApplicationWrapper.java:99)
        at org.mule.module.launcher.DefaultMuleDeployer.deploy(DefaultMuleDeployer.java:35)
        at org.mule.module.launcher.DeploymentService.start(DeploymentService.java:108)
        at org.mule.module.launcher.MuleContainer.start(MuleContainer.java:130)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.mule.module.reboot.MuleContainerWrapper.start(MuleContainerWrapper.java:64)
        at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:2788)
Caused by: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
        at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:43)
        ... 13 more
INFO  2010-12-16 14:25:57,072 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleApplication: Installing application: helloWorld
java.lang.RuntimeException: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
        at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:80)
        at org.mule.module.launcher.DefaultMuleSharedDomainClassLoader.<init>(DefaultMuleSharedDomainClassLoader.java:23)
        at org.mule.module.launcher.DefaultMuleApplication.createDeploymentClassLoader(DefaultMuleApplication.java:301)
        at org.mule.module.launcher.DefaultMuleApplication.install(DefaultMuleApplication.java:100)
        at org.mule.module.launcher.ApplicationWrapper.install(ApplicationWrapper.java:99)
        at org.mule.module.launcher.DefaultMuleDeployer.deploy(DefaultMuleDeployer.java:35)
        at org.mule.module.launcher.DeploymentService.start(DeploymentService.java:108)
        at org.mule.module.launcher.MuleContainer.start(MuleContainer.java:130)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.mule.module.reboot.MuleContainerWrapper.start(MuleContainerWrapper.java:64)
        at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:2788)
Caused by: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
        at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:43)
        ... 13 more
INFO  2010-12-16 14:25:57,082 [WrapperListener_start_runner] org.mule.module.launcher.DeploymentService: Application directory check interval: 5000

I'll worry about getting my example running corectly after I see that mule starts up correctly.

Thanks in advance for your time.

Eric Palmer

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: community 3.0.1 startup errors

Francis Upton-3
There is a lib/shared/default directory in your Mule kit, make sure that is present.

On Thu, Dec 16, 2010 at 2:49 PM, Eric Palmer <[hidden email]> wrote:
Centos 5.4 32 bit
JDK: 1.6.0_18 (Sun/Oracle)
Fresh install today
community 3.0.1

I have installed the hello and echo examples (unmodified) and as well was working on a config file using eclipse (helios) with the mule tools (and patched with the lastest mule tools patch http://dist.muleforge.org/mule-ide/wtp-patch/helios

When I run my new readFilePut example config in eclipse I don't get expected behavior but it does not throw java exceptions. When I just start up mule (command line or service (mule start)) mule throws these errors at startup.

Starting the Mule Container...
Wrapper (Version 3.2.3) http://wrapper.tanukisoftware.org
 Copyright 1999-2006 Tanuki Software, Inc.  All Rights Reserved.

INFO  2010-12-16 14:25:57,014 [WrapperListener_start_runner] org.mule.module.launcher.MuleContainer:
**********************************************************************
* Mule ESB and Integration Platform                                  *
* Version: 3.0.1 Build: Not Set                                      *
* MuleSoft, Inc.                                                     *
* For more information go to http://www.mulesoft.org                 *
*                                                                    *
* Server started: 12/16/10 2:25 PM                                   *
* JDK: 1.6.0_18 (mixed mode)                                         *
* OS: Linux (2.6.18-164.15.1.el5, i386)                              *
* Host: localhost.localdomain (127.0.0.1)                            *
**********************************************************************
INFO  2010-12-16 14:25:57,024 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleDeployer: Exploding a Mule application archive: file:/usr/local/mule-standalone-3.0.1/apps/mule-example-echo.zip
INFO  2010-12-16 14:25:57,049 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleApplication: Installing application: default
java.lang.RuntimeException: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
       at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:80)
       at org.mule.module.launcher.DefaultMuleSharedDomainClassLoader.<init>(DefaultMuleSharedDomainClassLoader.java:23)
       at org.mule.module.launcher.DefaultMuleApplication.createDeploymentClassLoader(DefaultMuleApplication.java:301)
       at org.mule.module.launcher.DefaultMuleApplication.install(DefaultMuleApplication.java:100)
       at org.mule.module.launcher.ApplicationWrapper.install(ApplicationWrapper.java:99)
       at org.mule.module.launcher.DefaultMuleDeployer.deploy(DefaultMuleDeployer.java:35)
       at org.mule.module.launcher.DeploymentService.start(DeploymentService.java:108)
       at org.mule.module.launcher.MuleContainer.start(MuleContainer.java:130)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:597)
       at org.mule.module.reboot.MuleContainerWrapper.start(MuleContainerWrapper.java:64)
       at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:2788)
Caused by: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
       at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:43)
       ... 13 more
INFO  2010-12-16 14:25:57,068 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleApplication: Installing application: mule-example-echo
java.lang.RuntimeException: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
       at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:80)
       at org.mule.module.launcher.DefaultMuleSharedDomainClassLoader.<init>(DefaultMuleSharedDomainClassLoader.java:23)
       at org.mule.module.launcher.DefaultMuleApplication.createDeploymentClassLoader(DefaultMuleApplication.java:301)
       at org.mule.module.launcher.DefaultMuleApplication.install(DefaultMuleApplication.java:100)
       at org.mule.module.launcher.ApplicationWrapper.install(ApplicationWrapper.java:99)
       at org.mule.module.launcher.DefaultMuleDeployer.deploy(DefaultMuleDeployer.java:35)
       at org.mule.module.launcher.DeploymentService.start(DeploymentService.java:108)
       at org.mule.module.launcher.MuleContainer.start(MuleContainer.java:130)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:597)
       at org.mule.module.reboot.MuleContainerWrapper.start(MuleContainerWrapper.java:64)
       at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:2788)
Caused by: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
       at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:43)
       ... 13 more
INFO  2010-12-16 14:25:57,070 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleApplication: Installing application: readFulePut
java.lang.RuntimeException: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
       at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:80)
       at org.mule.module.launcher.DefaultMuleSharedDomainClassLoader.<init>(DefaultMuleSharedDomainClassLoader.java:23)
       at org.mule.module.launcher.DefaultMuleApplication.createDeploymentClassLoader(DefaultMuleApplication.java:301)
       at org.mule.module.launcher.DefaultMuleApplication.install(DefaultMuleApplication.java:100)
       at org.mule.module.launcher.ApplicationWrapper.install(ApplicationWrapper.java:99)
       at org.mule.module.launcher.DefaultMuleDeployer.deploy(DefaultMuleDeployer.java:35)
       at org.mule.module.launcher.DeploymentService.start(DeploymentService.java:108)
       at org.mule.module.launcher.MuleContainer.start(MuleContainer.java:130)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:597)
       at org.mule.module.reboot.MuleContainerWrapper.start(MuleContainerWrapper.java:64)
       at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:2788)
Caused by: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
       at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:43)
       ... 13 more
INFO  2010-12-16 14:25:57,072 [WrapperListener_start_runner] org.mule.module.launcher.DefaultMuleApplication: Installing application: helloWorld
java.lang.RuntimeException: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
       at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:80)
       at org.mule.module.launcher.DefaultMuleSharedDomainClassLoader.<init>(DefaultMuleSharedDomainClassLoader.java:23)
       at org.mule.module.launcher.DefaultMuleApplication.createDeploymentClassLoader(DefaultMuleApplication.java:301)
       at org.mule.module.launcher.DefaultMuleApplication.install(DefaultMuleApplication.java:100)
       at org.mule.module.launcher.ApplicationWrapper.install(ApplicationWrapper.java:99)
       at org.mule.module.launcher.DefaultMuleDeployer.deploy(DefaultMuleDeployer.java:35)
       at org.mule.module.launcher.DeploymentService.start(DeploymentService.java:108)
       at org.mule.module.launcher.MuleContainer.start(MuleContainer.java:130)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:597)
       at org.mule.module.reboot.MuleContainerWrapper.start(MuleContainerWrapper.java:64)
       at org.tanukisoftware.wrapper.WrapperManager$12.run(WrapperManager.java:2788)
Caused by: java.lang.IllegalArgumentException: Shared ClassLoader Domain 'default' doesn't exist
       at org.mule.module.launcher.MuleSharedDomainClassLoader.<init>(MuleSharedDomainClassLoader.java:43)
       ... 13 more
INFO  2010-12-16 14:25:57,082 [WrapperListener_start_runner] org.mule.module.launcher.DeploymentService: Application directory check interval: 5000

I'll worry about getting my example running corectly after I see that mule starts up correctly.

Thanks in advance for your time.

Eric Palmer

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email





--
Francis Upton IV
President and CTO
Oakland Software
http://www.oaklandsoftware.com
Tel: 510 835 3123
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: community 3.0.1 startup errors

Adrian Brenes-2
Thanks.  That worked. Appreciate the fast response. Now I can get to debugging my first config example.

w00t

Eric Palmer

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: community 3.0.1 startup errors

Adrian Brenes-2
It worked. Just create a shared/default blank folder under lib.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: community 3.0.1 startup errors

huzefa.zoaib
This post has NOT been accepted by the mailing list yet.
We are facing the same issue.

We have installed the Mule Plugin in the Eclipse Kepler,
How can we the path of lib/shared/default ?
Or How can we find the path of Mule Kit in plugins of Eclipse Kepler.

We are stuck in the issue since many days, your help will be really appretiated.

Thanks In Advance,

Loading...