Quantcast

Mule 2.2.1-HF5 with Java 8.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Mule 2.2.1-HF5 with Java 8.

Raúl
This post has NOT been accepted by the mailing list yet.
This post was updated on .
I was wondering if anyone knows if Mule 2.2.1-HF5 could be executed with Java 8.

I have all my code developed in Java 6 with Mule 2.2.1-HF5 and, in order to migrate to Java 8 I will need to know if Mule 2.2.1-HF5 would be compatible with no code changes.

Thanks.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mule 2.2.1-HF5 with Java 8.

David Dossot
This post has NOT been accepted by the mailing list yet.
There should be no problem in term of byte code compatibility but I can foresee turbulence with libraries like the ones that are now part of the JDK, or even if you have JavaScript components, with the replacement of Rhino by Nashorn.

If you ask, I reckon you have a Mule app running on 2.2.1-HF5 so why don't you try it? Start your app, run your regression tests and report your finding here, as it may help others.

Cheers,
D.

PS. I thought this list was dead? Nowadays Mule discussion happen here http://forums.mulesoft.com/ or there http://stackoverflow.com/questions/tagged/mule

On Wed, Oct 28, 2015 at 3:52 AM, Raúl [via Mule] <[hidden email]> wrote:
I was wondering if anyone knows if Mule 2.2.1-HF5 could be executed with Java 8.



If you reply to this email, your message will be added to the discussion below:
http://mule.1045714.n5.nabble.com/Mule-2-2-1-HF5-with-Java-8-tp5723606.html
To start a new topic under Mule - Dev, email [hidden email]
To unsubscribe from Mule - Dev, click here.
NAML

Loading...